PDT/ZendDebugger Incompatible Debug Server version

Pleiades
から、
3.3.2.20080303 版のAll in Oneで
PDTを使っていた。

デバッグ実行が欲しくなり、
http://mergedoc.sourceforge.jp/index.html#/pleiades.html
を参考して、
ZendDebuggerを追加することに。

phpinfo()で
with Zend Debugger v5.2.14, Copyright (c) 1999-2008, by Zend Technologies
を確認して、
eclipseでデバッグ実行したら、
Incompatible Debug Server version
とアラートメッセージ。

[workspace]/.metadata/.log
を見たら、
!MESSAGE PHPDebugTarget: debugger.start return false
と書いてるけどよくわからん。

ネットで調べてみると
3.3.2.20080303 版のAll in Oneは、PDTのバージョン1.0.2対応で
Zend Debugger v5.2.14は、PDTのバージョン1.0.3対応らしい。

Zend Debugger v5.2.12は見つからないので、
http://www.eclipse.org/pdt/
から、pdt1.0.3のAll in Oneをダウンロードすると、
デバック実行が可能に。

----
ついでの覚書
pdtで、PHPのソースフォーマット
http://atlanto.web.fc2.com/pdt/workshop/formatter_plugin.html
Pluginは使い勝手がいい。

"PDT/ZendDebugger Incompatible Debug Server version" へのコメントを書く

お名前
メールアドレス
ホームページアドレス
コメント